Cloudflare System Status

Cloudflare Pages/Workers Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved. However, If you are not seeing the updated versions, we suggest to redeploy.
Posted Oct 18, 2023 - 02:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2023 - 00:23 UTC
Identified
Deployments to Workers should no longer be seeing issues.

Cloudflare Pages are still seeing some delays. We are continuing to work on a fix.
Posted Oct 17, 2023 - 23:39 UTC
Investigating
Cloudflare is aware of and investigating an issue with Cloudflare Pages build delays and worker deployments.

This does not affect existing deployments, we are currently investigating.
Posted Oct 17, 2023 - 22:53 UTC
This incident affected: Cloudflare Sites and Services (Pages, Workers).