Cloudflare System Status

Domain Registration Failures
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 17, 2023 - 11:25 UTC
Identified
Cloudflare has identified an issue which potentially causes new domain registrations to fail.
The root cause has been identified and a fix is being implemented.
Posted Oct 17, 2023 - 10:56 UTC
This incident affected: Cloudflare Sites and Services (Registrar).