Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident is now resolved.
Posted Apr 08, 2024 - 22:28 UTC
Monitoring
The issue has been identified and a fix has been implemented. We are currently monitoring the results.
Posted Apr 08, 2024 - 22:16 UTC
Investigating
Cloudflare is investigating delays in propagation of updates to DNS records. More updates to follow shortly.
Posted Apr 08, 2024 - 22:02 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).