Cloudflare System Status

Workers and Pages Builds not triggering

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 19:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2026 - 18:44 UTC

Update

Workers API has recovered. We have identified this issue is also impacting Pages builds. We are continuing to investigate.
Posted Feb 03, 2026 - 17:00 UTC

Update

We are also seeing some issues for the Workers API. Investigation is ongoing, we will share more information as it becomes available.
Posted Feb 03, 2026 - 16:56 UTC

Investigating

Cloudflare is aware of and investigating reports of an issue triggering Workers Builds from Git commits. We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Feb 03, 2026 - 16:09 UTC
This incident affected: Cloudflare Sites and Services (Pages, Workers Builds).