Cloudflare System Status

Internal DNS resolution impacting multiple services
Incident Report for Cloudflare
Resolved
A problematic DNS change was identified and rolled back. Impacted services (Cache Purge, Cache, and Turnstile) are now operating normally.
Posted Feb 28, 2023 - 17:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2023 - 16:59 UTC
Investigating
Some customers attempting to retrieve objects from R2 may experience increased latency. We are currently investigating.
Posted Feb 28, 2023 - 16:37 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache, Dashboard, R2, Turnstile).