Cloudflare System Status

Issues with Browser Isolation
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 23:08 UTC
Investigating
Cloudflare is investigating issues with the isolated browsing product. Some users on the isolated browser may encounter errors and blank page loads.
Posted Jan 13, 2022 - 21:43 UTC
This incident affected: Cloudflare Sites and Services (Browser Isolation).