Cloudflare System Status

Registrar

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 17:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 15, 2025 - 17:25 UTC

Investigating

Cloudflare is investigating issues with renewing domain registrations. Users attempting to renew domain registrations are experiencing errors.
Posted Oct 15, 2025 - 17:05 UTC
This incident affected: Cloudflare Sites and Services (Registrar).