Cloudflare System Status

Issues with TLS certificates using Lets Encrypt CA

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 31, 2026 - 08:55 UTC

Identified

The issue has been identified and a fix is being implemented.

Customers are advised to change to a different Certificate Authority as a workaround.
Posted May 31, 2026 - 06:41 UTC

Investigating

Cloudflare is investigating issues with Let's Encrypt certificates. Some visitors may experience TLS connectivity issues due to potentially unsupported CA bundling for a subset of Cloudflare customers.

Customers are advised to change to a different Certificate Authority as a workaround.
Posted May 31, 2026 - 03:16 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).