Minor ImpactLast updated: Refreshed just now
Cloudflare Billing Issues
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Monitoring
A fix has been implemented and we are monitoring the results.
- Identified
We are working on making Enterprise customer invoices available again through the dashboard.
- Investigating
Cloudflare is investigating a problem on the display of invoices for contract customers. Visualisation of invoices for those customers is impacted. We will provide an update once billing services return to normal.