Cloudflare System Status

Network Performance Issues in Jinan and Suzhou, China datacenter
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 03:00 UTC
Monitoring
A fix had been implemented and we are monitoring the result.
Posted Jul 21, 2020 - 02:59 UTC
Investigating
Cloudflare is investigating issues with network performance in Jinan and Suzhou, China datacenter

We are working to understand the full impact and mitigate this problem. More updates to follow shortly
Posted Jul 21, 2020 - 02:16 UTC