Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 15:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2022 - 14:45 UTC
Investigating
Cloudflare is investigating delays in propagation of updates to DNS records.

This only affects our free plan zones and not any paid plan zones.

More updates to follow shortly.
Posted Sep 12, 2022 - 14:41 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).