Cloudflare System Status

Issues with Newly Deployed Snippets

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 23:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 23:01 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 05, 2025 - 21:02 UTC

Investigating

We’ve identified an issue where newly deployed Snippets may not execute correctly at the edge. In some cases, this can result in exceptions being served to end users.

Snippets that were deployed prior to this incident continue to function normally, and there is no impact to the control plane, dashboard, or API.

We are actively investigating and working on a fix. As a temporary precaution, we recommend postponing critical production changes involving new Snippet deployments.

We will provide updates as soon as more information becomes available.
Posted Jun 05, 2025 - 20:58 UTC
This incident affected: Cloudflare Sites and Services (Snippets).