Cloudflare System Status

SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and SSL certificate issuance times have returned to normal.
Posted 4 months ago. May 23, 2018 - 17:00 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays.
We are observing delays in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.
Posted 4 months ago. May 23, 2018 - 12:40 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).