Cloudflare System Status

Increased Level of DNS Query Errors
Incident Report for Cloudflare
Resolved
This was determined not to be an incident on Cloudflare's side, but rather it was related to issues reaching customer origin DNS through their upstream provider.
Posted May 19, 2021 - 20:00 UTC
Investigating
Cloudflare is investigating an increased level of DNS query errors.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted May 19, 2021 - 14:15 UTC