Cloudflare System Status

Workers Cron Triggers delayed propagation to the edge
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 23:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 22:55 UTC
Investigating
Cloudflare is aware of, and investigating an issue where Workers Cron Triggers are delayed in propagating to the Cloudflare Edge Network. Further detail will be provided as more information becomes available.
Posted Nov 18, 2020 - 22:50 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Workers).