Cloudflare System Status

Long hold delays for Enterprise telephone support
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 20, 2022 - 21:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 21:17 UTC
Investigating
Our Enterprise telephone support system is currently experiencing issues - you may not be able to connect to report a technical issue via the phone. Please submit a ticket at https://dash.cloudflare.com/?to=/:account/support with your issue as an alternative, or if it's urgent - use live chat while logged into your Enterprise account on the Cloudflare dashboard.

We will issue further updates on this status page as we work with our providers to resolve this issue.
Posted May 20, 2022 - 20:36 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Support Site).