Cloudflare System Status

Network Connectivity issues in Western North America impacting R2 and Containers

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 18:26 UTC

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 17:01 UTC

Investigating

Customers may see increased latency while using R2 buckets and scheduling containers in the Western North America (WNAM) region
Posted Jun 10, 2026 - 16:35 UTC
This incident affects: Cloudflare Sites and Services (Containers, R2).