A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 19:19 UTC
Identified
The connectivity issues affecting Cloudflare Tunnel and Browser Isolation have stabilized, and we have identified the root cause.
Our investigation confirms that internal service restarts across our edge infrastructure led to significant connection churn. This caused active Cloudflare Tunnel connections and Browser Isolation sessions to disconnect and attempt to re-establish simultaneously. While this surge initially resulted in elevated error rates and registration failures, service health has now recovered, and connection success rates have returned to normal levels.
Most customers should see services operating normally at this time.
Posted May 05, 2026 - 17:24 UTC
Update
We are continuing to investigate this issue.
Posted May 05, 2026 - 16:58 UTC
Investigating
Cloudflare is investigating an issue causing connectivity disruptions for both Cloudflare Tunnel and Browser Isolation.
Initially identified as affecting only new connections, we have confirmed that existing connections might also be impacted. Due to internal service restarts across our edge infrastructure, currently active tunnels and sessions may be forced to reconnect. During this re-establishment process, customers may encounter elevated error rates or registration failures.
Our engineering team is prioritized on stabilizing the underlying services to allow connections to resume normal operations. We will provide frequent updates as we work toward a resolution.
Posted May 05, 2026 - 16:49 UTC
This incident affected: Cloudflare Sites and Services (Browser Isolation, Tunnel).