Cloudflare System Status

Workers Builds Issues

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted May 22, 2025 - 22:47 UTC

Monitoring

We have identified the cause of this issue and implemented a fix. We are currently monitoring the results.
Posted May 22, 2025 - 22:20 UTC

Investigating

Cloudflare is investigating an issue where a subset of Workers Builds are failing to initialize. We are actively working to identify and mitigate the problem. More updates to follow soon.
Posted May 22, 2025 - 20:31 UTC
This incident affected: Cloudflare Sites and Services (Workers).