Cloudflare System Status

Increased Errors in the Budapest region

Incident Report for Cloudflare

Update

We are continuing to investigate this issue.
Posted Mar 11, 2026 - 17:33 UTC

Investigating

Cloudflare One traffic routed through Cloudflare's Budapest point of presence may experience an increase in the frequency in timeouts.
Posted Mar 11, 2026 - 16:50 UTC
This incident affects: Europe (Budapest, Hungary - (BUD)) and Cloudflare Sites and Services (Cloudflare One Appliance).