Cloudflare System Status

Network Performance Issues in Wuxi, China
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 07:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2021 - 05:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2021 - 04:15 UTC
Investigating
Cloudflare is investigating issues with network performance in Wuxi, China, Customers may experience DNS and other configuration propagations delays ONLY when hitting WUX colo
We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Feb 26, 2021 - 03:46 UTC
This incident affected: Asia (Wuxi, China - (WUX)).