Cloudflare System Status

DNS Root Server Issues in Scotland

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 10:00 UTC

Investigating

Cloudflare is investigating issues that may impact DNS root servers for Scottish customers. We are currently working on a resolution and will provide an update as soon as possible.
Posted Apr 22, 2025 - 09:53 UTC
This incident affected: Cloudflare Sites and Services (DNS Root Servers, DNS Updates).