Cloudflare System Status

Configuration Change Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Jun 18, 2020 - 20:49 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 18, 2020 - 20:44 UTC
Monitoring
Cloudflare has identified the issue and a fix for this issue is currently being implemented. We are monitoring the results.

We will update the status once the issue is resolved.
Posted Jun 18, 2020 - 18:39 UTC
Investigating
Cloudflare is investigating delays in our ability to process events for alerts set by customers, email delivery events, and DNS configuration changes. We are actively working to solve this issue.
Posted Jun 18, 2020 - 17:38 UTC
This incident affected: Cloudflare Sites and Services (Analytics, DNS Updates).