Cloudflare System Status

Increased failures on DNS record modifications

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 17, 2024 - 23:19 UTC

Monitoring

We have identified the issue and updates start to catch up.
Posted Jun 17, 2024 - 23:04 UTC

Identified

The failures could include:

1. Propagation delays of newly created records;
2. Update delay of existing records;
3. Failure to save changes of existing records;
4. Some other Cloudflare features relying on DNS may not function correctly, like Cloudflare Pages custom domain initialization failures.

More updates to follow shortly.
Posted Jun 17, 2024 - 22:58 UTC

Investigating

Cloudflare is investigating issues with DNS record modifications.
Posted Jun 17, 2024 - 22:53 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).