Cloudflare System Status

Cloudflare Registrar unable to process operations for Identity Digital TLD domains

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jan 10, 2023 - 20:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 10, 2023 - 16:58 UTC

Investigating

Cloudflare is investigating issues with its Registrar services that impact some customers with Identity Digital TLD domains for new registrations, transfers and renewals operations.

See https://www.cloudflare.com/tld-policies/ for the list of Identity Digital TLDs.

Registration services for other TLDs are not impacted.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jan 10, 2023 - 16:08 UTC
This incident affected: Cloudflare Sites and Services (Registrar).