Cloudflare System Status

Performance degradation in Paris, France

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 10:46 UTC

Investigating

Some users in Paris, France may experience increased latency or timeouts.
Posted Mar 03, 2026 - 09:17 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache) and Europe (Paris, France - (CDG)).