Cloudflare System Status

Canadian Billing Address Fails Validation in Registrar

Incident Report for Cloudflare

Resolved

An effective fix for this issue has been deployed and this incident is now resolved.
Posted Oct 02, 2025 - 18:42 UTC

Identified

The cause of this issue has been identified and a fix is being implemented.
Posted Oct 02, 2025 - 18:02 UTC

Investigating

Billing validation is failing in Registrar for Canadian billing addresses. This is impacting domain name registration and transfers. The team is investigating.
Posted Oct 02, 2025 - 17:51 UTC
This incident affected: Cloudflare Sites and Services (API, Dashboard).