Cloudflare System Status

Connection failures for some Cloudflare zones

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Jul 10, 2025 - 21:58 UTC

Monitoring

Cloudflare has identified an issue resulting in connection failures for some zones. We have applied a fix for this issue and are currently monitoring the results.
Posted Jul 10, 2025 - 21:39 UTC
This incident affected: Cloudflare Sites and Services (Network).