Cloudflare System Status

Email Delivery Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 09:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2022 - 09:17 UTC
Investigating
Cloudflare is investigating a delay in our ability to send emails. This includes password reset, mFA token emails. We are working to resolve the issue. More updates to follow shortly.
Posted Sep 22, 2022 - 09:14 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Dashboard).