Cloudflare System Status

Cloudflare Images upload failures

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 17:21 UTC

Investigating

Cloudflare is aware of, and investigating an issue which potentially impacts customers trying to upload new files to Cloudflare Images.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 10, 2026 - 15:53 UTC
This incident affects: Cloudflare Sites and Services (Images).