Email Security delivery impacted by Spamhaus listing
Timeline
- Updated
We are continuing to investigate this issue. Customers using O365 will be impacted only if they have not completed the required setup. Please check your setup and ensure the connector includes all egress IPs: https://developers.cloudflare.com/cloudflare-one/email-security/setup/pre-delivery-deployment/prerequisites/m365-email-security-mx/#2-configure-enhanced-filtering
- Updated
We are continuing to investigate this issue.
- Investigating
We are currently investigating an issue where customers that use Spamhaus for additional filtering of email downstream from the Cloudflare Email Security service are rejecting emails from IPs in the 134.195.26.0/23 block. This IP block should be allowed for all customer downstream systems to avoid treating the Email Security service as an originator of mail. We recommend all Cloudflare Email Security customers disable Spamhaus filtering in downstream systems.