Cloudflare System Status

Billing Service Maintenance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 13, 2019 - 02:45 UTC
Investigating
We are performing maintenance on our Argo subscription services. For several hours you may see a delay in processing changes to subscriptions. All other services are operating normally. We will post an update once the maintenance is complete.
Posted 2 months ago. Aug 12, 2019 - 20:40 UTC
This incident affected: Cloudflare Sites and Services (Billing).