Cloudflare System Status

Network Performance Issues in Madrid, Spain
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 15:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2022 - 15:02 UTC
Investigating
Cloudflare is investigating issues with network performance in Madrid.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Jan 11, 2022 - 15:00 UTC
This incident affected: Europe (Madrid, Spain - (MAD)).