Cloudflare System Status

Network Performance Issues

Incident Report for Cloudflare

Update

We are continuing to investigate this issue.
Posted Dec 19, 2025 - 16:55 UTC

Update

We are continuing to investigate this issue.
Posted Dec 19, 2025 - 16:29 UTC

Update

We are continuing to investigate this issue.
Posted Dec 19, 2025 - 16:10 UTC

Update

We are continuing to investigate this issue.
Posted Dec 19, 2025 - 15:45 UTC

Investigating

Cloudflare is investigating intermittent issues with network performance. Customers might observe unexpected errors. We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Dec 19, 2025 - 15:06 UTC
This incident affects: Cloudflare Sites and Services (Network).