Cloudflare System Status

Cloudflare Dashboard service issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 06:57 UTC

Monitoring

Services have been restored and we are continuing monitoring.
Posted Oct 08, 2025 - 04:59 UTC

Investigating

Cloudflare is investigating issues with Cloudflare Dashboard and Worker Builds.

Customers using the Dashboard may be impacted as requests might fail and/or errors may be displayed.
Posted Oct 08, 2025 - 04:22 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).