Cloudflare System Status

DNS Update Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 21, 2022 - 13:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2022 - 11:01 UTC

Investigating

Cloudflare is investigating delays of up to 10 minutes for updates to DNS records. This delay also affects provisioning SSL certificates and new Cloudflare Tunnel instances.

DNS resolution, existing SSL certificates, and established Cloudflare Tunnels are not impacted. More updates to follow shortly.
Posted Apr 21, 2022 - 10:13 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).