Cloudflare System Status

Page Rule Change and Cache Purge Delay
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 26 days ago. Sep 28, 2018 - 02:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 26 days ago. Sep 28, 2018 - 02:40 UTC
Investigating
Cloudflare is investigating Page Rule and Cache Purge delays. Page Rule Update delays are taking up to 72 minutes. This only affects Page Rule updates and changes.

Cloudflare Page Rule service delivery is unaffected and is operating normally.
Posted 26 days ago. Sep 28, 2018 - 00:21 UTC