Cloudflare System Status

Elevated errors and latency in Singapore region

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 09:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2025 - 09:02 UTC

Investigating

Cloudflare has detected increased latency and elevated error rates for customers in Singapore. The issue has been identified and a fix is being implemented. More updates to follow shortly.
Posted Jul 31, 2025 - 08:36 UTC
This incident affected: Asia (Singapore, Singapore - (SIN)).