Cloudflare System Status

Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved
Posted 6 months ago. Mar 12, 2018 - 01:23 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 6 months ago. Mar 11, 2018 - 23:01 UTC
Investigating
We are currently investigating problems with our billing service.
Posted 6 months ago. Mar 11, 2018 - 20:50 UTC