Minor ImpactLast updated: Refreshed just now
Email Notifications Delayed
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Investigating
Cloudflare is investigating delays with dispatching of notification emails for some customers. Webhooks and PagerDuty notifications are not affected.