Cloudflare System Status

Cloudflare R2 Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 04:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 04:38 UTC

Identified

Cloudflare is investigating elevated error rates affecting R2 and some services that depend on it, including Stream, Pipelines, and Log Explorer. Customers may have experienced increased errors reading or writing objects and delayed data processing. Impact was partially mitigated at approximately 21:52 UTC, and dependent services have recovered. A low level of R2 errors is still occurring, and we are actively working toward full resolution.
Posted Jul 16, 2026 - 01:12 UTC
This incident affected: Cloudflare Sites and Services (Log Explorer, R2, Stream).