A fix has been implemented and we are currently monitoring the results.
Posted May 16, 2026 - 22:43 UTC
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted May 16, 2026 - 19:13 UTC
Investigating
Cloudflare is aware of and investigating issues paying for products with PayPal. Customers may experience an error when attempting to purchase or renew a product using PayPal. We are working to mitigate this problem. More updates to follow shortly.
Posted May 16, 2026 - 17:54 UTC
This incident affects: Cloudflare Sites and Services (Billing).