Cloudflare System Status

Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 17, 2017 - 12:03 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted Jun 16, 2017 - 03:08 UTC
Investigating
We are having trouble processing payments.
Posted Jun 15, 2017 - 23:18 UTC
This incident affected: Cloudflare Sites and Services (Billing).