Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 11, 2019 - 01:01 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted 2 months ago. Mar 11, 2019 - 00:42 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted 2 months ago. Mar 10, 2019 - 22:53 UTC
Investigating
Cloudflare is investigating delays of up to 60 minutes in updates to DNS records. These delays only affect record changes and updates.

DNS resolution is operating normally.
Posted 2 months ago. Mar 10, 2019 - 22:14 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).