Cloudflare System Status

Issue with Geo Key Manager (SSL)
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and Geo Key Manager services have resumed normal operation.
Posted about 1 month ago. Nov 12, 2018 - 22:30 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted about 1 month ago. Nov 12, 2018 - 21:53 UTC
Investigating
Cloudflare is investigating issue with Geo Key Manager. Customers who are using Geo Key Manager (for Custom SSL certificate) may be affected.
Posted about 1 month ago. Nov 12, 2018 - 21:05 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).