Cloudflare System Status

Delay in Registrar domain renewal processing
Incident Report for Cloudflare
Resolved
The incident has been resolved
Posted Aug 12, 2020 - 19:38 UTC
Monitoring
Cloudflare has implemented a fix and is working on processing the renewals from August 8th to now.
Posted Aug 12, 2020 - 17:07 UTC
Identified
Cloudflare has identified the issue with processing domain renewals and a fix is being implemented.
Posted Aug 12, 2020 - 16:31 UTC
Investigating
Cloudflare is experiencing problems in processing renewals for domains on Cloudflare Registrar. This is affecting domain renewals from the 8th of August onwards.

We will provide an update once Registrar renewal services return to normal.
Posted Aug 12, 2020 - 15:53 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Registrar).