Cloudflare System Status

DNS resolution intermittently failing for .co domains

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 21:55 UTC

Investigating

Cloudflare is aware of DNS resolution intermittently failing for domains using .co ccTLD.

We are trying to reach the ccTLD operator to resolve this issue.
Posted Apr 17, 2026 - 21:50 UTC
This incident affects: Cloudflare Sites and Services (Recursive DNS).