Cloudflare System Status

Unexpected Workers Build Termination

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Nov 07, 2025 - 00:22 UTC

Monitoring

We have identified the cause of this issue and implemented a fix. We are currently monitoring the results.
Posted Nov 06, 2025 - 23:13 UTC

Investigating

Cloudflare is aware of and investigating an issue causing an increased rate of Workers Builds to terminate unexpectedly. More updates to follow shortly.
Posted Nov 06, 2025 - 22:15 UTC
This incident affected: Cloudflare Sites and Services (Workers Builds).