Cloudflare System Status

Network failures in Madrid
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 15:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2020 - 15:20 UTC
Investigating
Cloudflare is investigating network failures in Madrid causing congestion.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jul 20, 2020 - 15:18 UTC
This incident affected: Europe (Madrid, Spain - (MAD)).