Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 15:25 UTC
Investigating
Cloudflare is investigating delays for updates to DNS records. This delay also affects provisioning SSL certificates and new Argo Tunnel instances.

DNS resolution, existing SSL certificates, and established Argo Tunnels are not impacted. More updates to follow shortly.
Posted Jun 15, 2021 - 13:57 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).